Plesk 9.2.1 Greylisting

In case, like me, you’re having trouble enabling the newly supported ‘Greylisting’ feature after upgrading Plesk to 9.2.1, I managed to find the solution.
Every time I tried to enable Greylisting I got
Failed to exec glmng cli. file does not exist or is not executable: / usr / local / psa / admin / bin / glmng
It seems that the Updater from the Control Panel fails to complete all the tasks necessary. Thankfully I found a blog post on huschi.net which explained how to complete upgrading manually.
/usr/local/psa/admin/bin/autoinstaller
and then proceed through the remaining screens using ‘Enter’ for the default Next Page action.
After that the option to enable Greylisting doesn’t produce the error.